1 reply [Last post]
btanner
Offline
Joined: 2010-04-13

I'm trying to use the JarBundler ANT task to create an OS X executable application with Docmosis tucked away inside.

This is just for internal use at our office. The users of the application are not particularly tech savvy and I thought it would be nice to have the whole application bundled into a single, self-contained, draggable, copyable, clickable Mac program.

I'm using this ant task:
http://informagen.com/JarBundler/

Seems to actually be working, except when I try to actually render my document Docmosis explodes because it can't initialize the converter pool. It can't find the docmosis.properties file either, but I can remedy that by passing my properties through VM arguments. I have tried copying the properties and converter xml file into the bundle, I have tried adding classpath entries for it outside of the bundle, etc. I'm probably missing something dumb, but nevertheless I can't get it to work.

Any ideas on either how to debug this, how to fix it, or how to pass in the details about the converter pool directly? I probably have the simplest setup one could imagine:

Any help? I'm stalled.

btanner
Offline
Joined: 2010-04-13
Just a quick update, I got

Just a quick update, I got this all sorted. It's important to add a classpath entry for the DIRECTORY that has your .properties and .xml files, not to specifically add them as files to the classpath.

Here is a copy of my build task (a bit ugly)
<target name="-post-jar">
<copydir src="lib" dest="dist/lib" />
<jarbundler dir="release"
name="FirePlanner"
vmoptions="-ea"
mainclass="com.fireplan.main.main"
jvmarchs="i386"
extraclasspath="$JAVAROOT/../"
build="${svn.revision.version}"
icon="fireplannericon.icns"
splashfile="fireplannersplash.png"
version=".9 Beta"
>
<jarfileset dir="dist">
<include name="**/*.jar" />
</jarfileset>

<resourcefilelist id="propertyFiles" dir="." files="converterPoolConfig.xml docmosis.properties"/>
<resourcefilelist id="imageFiles" dir="src/images" files="fireplannericon.png fireplannersplash.png fireplannericon.icns"/>
</jarbundler>
</target>